Reaction Editor

From SysCAD Documentation
Jump to: navigation, search

Navigation: User Guide -> Editors and Utilities -> Reaction Editor

Reaction Format Reaction Block (RB) Sub Model Heat of Reaction
Reaction Editor Text File Format Reaction Block (RB) Summary Solving Order - Sequential or Simultaneous Reaction Extents Individual Reactions Source /Sink /Heat Exchange Energy Balance Heat of Reaction Heat of Dilution Partial Pressures of Gases

Introduction

With all the features it provides, the SysCAD Reaction Editor makes it easier to create and edit reaction files. Therefore, we highly recommend our SysCAD users install it.

It is available with the latest install version of SysCAD, or from the Download section of our website (https://www.syscad.net/login/).

Video Links

These short video clips are available in the Tutorial Section of the Help documentation, or directly in YouTube.

Set up the Reaction Editor

Installing the SysCAD Reaction Editor

  1. When SysCAD is installed there is an option to install the Reaction Editor. If this option was selected then there is nothing more to do.
  2. If Reaction Editor wasn't installed as part of the SysCAD install then the user needs to obtain a copy of the Reaction Editor installation file. They can obtain this:
    • From the folder \Syscad9x\Setup\ReactionEditor
    • By downloading it from the SysCAD Downloads Page (https://www.syscad.net/login/). Once you have downloaded the zip file, you can unzip the installer for the Reaction Editor.
    • Run the Reaction Editor installer file (.msi) and follow the steps outlined in the dialog boxes. If the default settings are used, the Reaction Editor will be installed in the folder C:\Program Files\SysCAD.
  3. For SysCAD 9.3 Build 137: The Reaction Editor uses the .net framework (version 4.5).
  4. For SysCAD 9.2: The Reaction Editor uses the .net framework (version 2.0).

How to Set the SysCAD Reaction Editor as the Default editor

In SysCAD, select menu command Tools - General Options- General Tab page, under Editors (bottom option)

  • if the reaction editor was installed using the default settings, then the path should have already been entered.
  • If not, either press the Defaults button to add the default location or use the Browse... button and enter the path of the Reaction Editor.

The default path as shown below:

GeneralOptions RxnEd.png

Once this is done, the next time you press the Edit_RCT in SysCAD (See Reaction Block (RB)), the SysCAD Reaction Editor will start up.

Note: You may still open the reaction files with a text editor, such as Notepad, Notepad++, Textpad, etc, outside of SysCAD, if required. You do not need to run SysCAD to use the Reaction Editor, so you can view and/or edit reaction files without loading a project.

Reaction Editor Options

On the main Reaction Editor Edit menu, there is an Options field.

This field has two options which can be enabled or disabled:

  1. Autoload All On Startup: If enabled, all reactions files in the current project will be loaded when the reaction editor is first launched
  2. Enforce Charge Balance: If enabled, Charge imbalances in reactions will be reported as errors. This is a new option only available in a recent version of Reaction Editor (v1.2 or later) and only works with SysCAD 9.3 projects where charge can be specified as part of the species definition in the Species Database.

Reaction Files

Location of Reaction Files

When a new project is created, a sub-folder called Reactions is automatically added, any reactions created within the project will be automatically added to this folder. This is shown for the Demo Nickel Copper Project, below:

General - Reaction Folder Path.png

This folder contains the file 'SpecieDate.ini', which contains all of the information about the species used within the project. The SysCAD Reaction Editor uses the information in this file to display the available species, determine if reactions are balanced, autobalance reactions, if required, etc. The SysCAD Reaction Editor will automatically save any new reaction files into this folder.

Note: If the user opens an existing project that was created in an earlier build of SysCAD, they should check if the reaction files are stored within the project. If not then they should create the 'Reactions' sub-folder within the project and copy all of the required reactions into this folder.

Opening Existing Reaction Files

Once SysCAD has been set to use Reaction Editor (see How to Set SysCAD to use the SysCAD Reaction Editor), reaction files can be opened from SysCAD by pressing the 'Edit RCT' button.

The SysCAD Reaction Editor will start up and open all reaction files in the current project with the selected one being in the current window. See example below:

Reactions - Reaction Editor 1.png

The species used in the currently selected reaction are in bold and in blue in the species list in the right hand side window. The species used in other reactions in the current reaction file are in bold and in black in the species list in the right hand side window.

The log window will display any messages/warnings/errors found by the Reaction Editor. To clear the log go to View-Clear Log.

Existing Reaction Files can be opened from the SysCAD Reaction Editor without running SysCAD. Start up the Reaction Editor from the start menu. Go to File-Open and select the reaction file to open. The Reaction Editor will then open the reaction file and the associated database. Alternatively, the user can go to File-Open Folder and select the reactions folder for a particular project. The Reaction Editor will then open all reaction files in the folder and the associated list of project species.

If a reaction file had previously been edited manually using a text editor, the SysCAD Reaction Editor will upgrade the file. This will perform some formating on the file when it is next saved. CAUTION: In same cases where there are simultaneous reactions and they are listed in an unusual order, then the reaction editor may renumber the reactions.

Closing Reaction Files

Reaction files can be individually closed either by using the menu command File-Close or clicking on the X in the top right corner of the reaction window. If a file has been changed it will be blue in the left hand side window and have an '*' next to the file name on the top of the reaction window. If there are any unsaved changes to the file, the user will be asked if they wish to save the file prior to it being closed.

Creating a New Reaction File

The first time a reaction file is created in a project, the Reaction Editor will open with the following display:

Reactions - Add Reaction 2.png

The window on the Left Hand Side, Files, contains a list of all of the reaction files in the project. In this case there is only one file, as this is a new project with no existing reaction files.

The window on the Right Hand side, Species, contains a list of all of the species in the project. This list is obtained from the configuration file, and hence will change when the user changes that file.

The Reaction Display Window will contain all reactions, any sinks or sources that the user specifies and heat exchange, if required.

  • The Reaction window will start with a blank reaction as the reaction file is created. Please see Adding a New Reaction for information on how to add the reactants and products.
  • To add more information to the reaction file, use the Add Reaction button to add another Reaction or clicks on the Add Other button to add either a Source, Sink or Heat Exchange.

Editing the Reactions

Adding a New Reaction

The image below shows a new reaction being added:

Reactions - Add Reaction.png


  1. Drag the species to the Reactant and Product boxes to form the reaction.
  2. Balance the reaction (see next heading)
  3. Specify the reaction extent - type, values, and the extent species. Please see Reaction Extents for more detail.
  4. SysCAD normally uses the Heats of Formation of the products and reactants to calculate the Heat of Reaction. However, if Heat of Formation value is missing in the species database for any compounds involved in the reaction, then user will need to tick the Override tick box and specify a user defined Heat of Reaction.

Once a reaction has been entered, its status will be shown just above the log window on the status line.

Note: Users should FIRST drag species into the Reactant and Product boxes and THEN adjust the number of moles of each species reacting, or use the automatic balance functionality.

Balancing the Reaction

If the reaction has been fully specified but not balanced then a message will be displayed in the status line.

For example, when adding the Ferrous to Ferric reaction, after dragging the compounds into the reaction and product fields, we may have

1 FeSO4(aq) + 1 O2(g) + 1 H2SO4(aq) = 1 Fe2[SO4]3(aq) + 1 H2O(l)

This reaction is not balanced, user will find a message displayed in the Status bar:

Status: Imbalanced. Excess product elements: {Fe = 1}, {S = 1}, {O = 3}.

To balance the reaction, either

  • manually entering the number of moles of each species in the reaction;
  • Or press the Balance button for suggestion from SysCAD. User can choose to accept or reject the suggestion.

When the 'Balance' button is pressed, the Reaction Editor will attempt to balance the active reaction with the specified Reactants and Products. Depending on the state of the reaction, one of the following dialog boxes will be displayed:

1. The Reactants and Products are all correctly specified, but the numbers of moles may need adjusting:

Reaction Editor Balancer 1.png

The Autobalancer will display both the original and the balanced reaction and the user may accept the changes by clicking on the 'OK' button, or reject the changes and go back to the Reaction Editor by clicking on the 'Cancel' button (in this case they will balance the reaction themselves)

2. There are insufficient Reactant or Product species for the reaction to be balanced:

Reaction Editor Balancer 2.png

In this case the user may choose to:

  • Click on the 'Cancel' button and return to the Reaction Editor and drag additional species to the Reactant or Product side to ensure that the correct species are available; OR
  • Use a previously specified 'Set' of species, or specify a new Set of species that will be useful when balancing reactions. In the dialog box above there are no previous species Sets specified, and hence the user will need to enter a name for a new species Set and then type in the required species (you cannot drag species into this dialog box).
    This functionality is especially useful when the user has a number of reactions that involve the same reagent and by-product.
  • Please see Video Links for a video showing you how to set up and use a Species Group in the Reaction Editor.

Specifying the Reaction Order

By default, SysCAD reactions are added sequentially. The reaction order is as they appear in the reaction file. To change the order of the reactions in the reaction file, select the desired reaction in the reaction window and click the up and down arrow buttons to move to the desired place in the reaction file.

Note: If included, sources will always be first, sinks will always be last or second last and heat exchange will always be last. Hence none of these can be moved.

Alternatively, user can choose to specify two or more simultaneous reactions. Please see Sequences Enabled.

Adding a New Source

  1. Click on Add Other and select Source.
  2. Type in the required source/s in the Sources box, or drag them into the Sources box from the species list in the right hand side window.
  3. Any species being used a source will have a Source icon.png icon displayed next to it.

Note: You may only add a Source once to a reaction file, but you can add multiple species to a single Source.

Reaction Source.png

When editing a reaction file from SysCAD 9.3, an additional dropdown list will appear next to the Enabled tickbox in the bottom left of the reaction editing panel.

Source Options.png

Please see Reaction Source for more information.

Adding a New Sink

Click on Add Other and select Sink. Type in the required sink/s in the Sinks box, or drag them into the Sinks box from the species list in the right hand side window.

Any species being used a sink will have a Sink icon.png icon displayed next to it.

Note: You may only add a Sink once to a reaction file, but you can add multiple species to a single Sink.

Please see Reaction Sinks for more information.

Adding Heat Exchange

  1. To add Heat Exchange, click on Add Other and select Heat Exchange.
  2. In the Heat Exchange box, select the appropriate option from the drop down list and then specify the value of associated variables depending on options chosen.
  3. These options are explained in Reaction Heat Exchange.

Remove a Reaction, Source, Sink or Heat Exchange

To remove a reaction, source, sink or heat exchange, simply select it in the reaction window and click Remove.

Note: If you only wish to disable the reaction, source, sink or heat exchange, clear the Enabled box at the bottom of the reaction window.

Clone a Reaction

The user may wish to clone a reaction when a very similar reaction is required. Select the required reaction in the reaction window and click Clone. A new reaction will be created at the bottom of the list which can be edited as for other reactions.

NOTE: when editing a cloned reaction, be sure to check the extent species as this may have changed, especially if the "old" compound has been deleted.

Copying Reactions from other files

Reactions can be easily copied from one reaction file to another using the Reaction Editor.

If the reaction files are in the same project, with the Files pane open, drag the reaction to be copied with the left mouse, hold down and drop it into the other reaction file.

Reaction editor 3.png

To copy a reaction from a reaction file in a different project, open the reaction files in different instances of the Reaction Editor. Select the reaction to be copied, right mouse click and select copy. Go to the other instance of Reaction Editor, right click on the reaction window of the desired reaction file and select paste.

Options

For every reaction file there is a Options tab. Click on the tab to access the Options tab. An example is shown below.

Reaction Editor Options.png


On this tab allows the user may enable the following:

Sequences Enabled

  • This causes the reactions to be solved simultaneously, if required. This is NOT the recommended solution method - please see Reaction Block - Solving Reactions for more information.
  • Each reaction will automatically be assigned a Sequence number of 1 - which means that all of the reactions are placed in sequence 1 and solved simultaneously.
  • The user may change the sequence number of a reaction on the Reactions tab and hence create groups of reactions. Each group of reactions is solved simultaneously.

Always Use First Reactant for Extent

  • This allows the user to specify that the first reactant is always to be used for the extent for the reactions in this reaction file.
  • Normally when a reaction is inserted the default extent species used is the first reactant, but the user may change this. If this option is enabled, then the user cannot change the extent species.

Description

  • Add any comments to the description box for this reaction file.
  • Any comments which were previously in a reaction file created without the Reaction Editor will be automatically moved to the description box. The date that the file was first saved using the Reaction Editor will automatically be noted in the description box as shown in the example above.